Resolved
The app is no longer stuck restarting and the 503 has been resolved. A transient network issue was also occurring that coincided with Emergency Network Maintenance done by our hosting provider.
Monitoring
We identified the issue related to backend analytics and that it was failing during the app's startup, causing it to restart in a loop. A fix has been issued and we will be monitoring to make sure that the issue is fully resolved.
Investigating
The app is displaying a 503 Service Unavailable error and cannot be accessed.