A mitigation has been put in place which has resolved the issue. A longer term fix will be worked on to fully resolve the issue. The cause was a recent adoption of a sign-in feature that Google rolled out seemingly unannounced, which broke our system's sign-in flow. The mitigation adds support for this feature at a higher-level which removes the need for the app code to change. The long term fix will be to update the application so it supports this new feature.
Resolved
A mitigation has been put in place which has resolved the issue. A longer term fix will be worked on to fully resolve the issue. The cause was a recent adoption of a sign-in feature that Google rolled out seemingly unannounced, which broke our system's sign-in flow. The mitigation adds support for this feature at a higher-level which removes the need for the app code to change. The long term fix will be to update the application so it supports this new feature.
Identified
We believe we have identified the problem. A recent change in the Google Sign-in flow is unsupported in our current system and it is causing a mismatch when redirecting back to KTOMG.
Earliest signs of this issue appeared in mid-February.
There should be a way to fix this in the interim but longer term we will need to update the authentication infrastructure we're using internally. We will work on mitigating this during business hours on February 28 since it is after-hours right now.
Investigating
After some preliminary investigation, we have ruled out any configuration changes on our side. No code changes were made recently that affected login systems either.
This may be a change in the external Google Sign-in system and we are still investigating what the cause might be.
Investigating
Google Sign-in is failing. It is unknown yet whether the cause is due to a recent app deployment or if Google is having widespread issues.
As a workaround, if you have a username/password, you can sign-in to the site that way until this incident is resolved.