Resolved
Cloudflare's fix seems to have resolved the issue and our alerts are no longer firing.
Monitoring
Cloudflare has implemented a fix and the issue may be resolved. The site is now back up but may experience degraded performance if there are any follow-up issues.
Identified
The website is unavailable until Cloudflare can resolve their global network outage.